ionCube Loader là tlỗi viện PHPhường cần sử dụng với phần đông tệp tin được mã hóa do phần mềm ionCube Encoder.

Bạn đang xem:

*

Trong bài viết này, bản thân đang trả lời chúng ta bí quyết thiết lập ionCube trên hệ thống thiết đặt thongcongnghetaz.com Script.

Các server không giống cũng làm việc tương tự!

Hướng dẫn thiết lập ionCube Loader

1. Tải ionCube Loader

trước hết bạn cần soát sổ coi hệ thống sẽ thực hiện là 32bit tốt 64bit bằng cách chạy lệnh:

uname -a

*

Nếu câu chữ trả về là x86_64 có nghĩa là 64bit, ngược lại i386 là 32bit.

Với hệ thống 64bit x86_64

cd /tmpwget http://downloads.ioncube.com/loader_downloads/ioncube_loaders_lin_x86-64.tar.gztar xfz ioncube_loaders_lin_x86-64.tar.gzVới hệ thống 32bit i386

cd /tmpwget http://downloads.ioncube.com/loader_downloads/ioncube_loaders_lin_x86.tar.gztar xfz ioncube_loaders_lin_x86.tar.gz

2. Lựa chọn phiên phiên bản ionCube Loader

Khi các bạn cần sử dụng lệnh ls /tmp/ioncube đã thấy tương đối nhiều phiên bản ionCube Loader khớp ứng cùng với phiên bản PHPhường. khác nhau, bước tiếp theo rất cần được sàng lọc phiên bản ionCube Loader phù hợp cùng với khối hệ thống hiện giờ.

*

– Kiểm tra phiên bạn dạng PHPhường hiện tại tại

php -vOutput đầu ra trả về hoàn toàn có thể giống như nlỗi sau:

– Tìm kiếm thỏng mục chứa thư viện mở rộng của PHP:

php -i | grep extension_dirextension_dir => /usr/lib64/php/modules => /usr/lib64/php/modulessqlite3.extension_dir => no value => no value– Copy phiên bản ionCube Loader cho PHP 7.3 vào thư mục /usr/lib64/php/modules

cp /tmp/ioncube/ioncube_loader_lin_7.3.so /usr/lib64/php/modulesNếu bạn đang thực hiện phiên bản PHP. không giống 7.3, hãy thay thế tên tệp tin tương ứng.

3. Cấu hình PHPhường áp dụng ionCube Loader

Mlàm việc tệp tin cấu hình PHP

nano /etc/php.iniThêm đoạn sau vào cuối file

zend_extension = /usr/lib64/php/modules/ioncube_loader_lin_7.3.soKhởi rượu cồn lại service

service php-fpm restartservice nginx restart

4. Kiểm tra kết quả

Nếu không có vụ việc gì xảy ra, khi thực hiện lệnh php -v bạn sẽ thấy thêm 1 dòng ionCube PHP.. Loader lộ diện dưới.

Chúc bạn thành công xuất sắc.

Xem thêm: Nước Khoáng Lavie Giá Nước Khoáng Lavie Bình 20 Lít, Nước Khoáng Lavie Bình 20 Lít Giá Bao Nhiêu


*

Mình ko rành, đề nghị tuân theo lý giải của doanh nghiệp, giờ đồng hồ vào tệp tin php.ini ko có gì cả, chỉ gồm 2 cái nhỏng bạn chỉ, vậy hiện nay đề nghị làm sao? Ko biết thông thường file kia chứa gì nữa.Thank Luân


*

Vậy cấu hình php của khách hàng không lưu giữ trong các số đó phải vốn dĩ tệp tin kia White. Tùy từng bộ script nhưng địa chỉ lưu giữ không giống nhau cần bạn phải search rồiThông qua những lệnh nhưphp -iphp --versionwhereis phpVà ngồi đọc các báo cáo để hiểu thông số kỹ thuật PHPhường. giữ sinh hoạt đâu


*

Thank Luân. Nhờ gợi nhắc của luân mình kiếm được rồi. Nó phía trong /etc/php/7.0/cli/php.ini


*

Cấu hình vậy có thể các bạn là Centmin Mod tốt VestaCP à?


*

Cho em hỏi sau khoản thời gian download xong thì muốn mã hóa các file mình phải thì có tác dụng ntn ạ?


*

Mình sở hữu nhưng lại bị lỗi này

Cannot load the ionCube PHPhường Loader – it was already loaded

Mong admin giúp sức ah.


*

Cho mình nội dung của /etc/php.ini. Và khối hệ thống bạn là gì? Vì hoàn toàn có thể vào /etc/php.d/ tất cả file cũng đang thông số kỹ thuật ionCube rồi


*

php.ini em xem khôn xiết kỹ cùng cấu hình đúng ùi ạ.Anh hoàn toàn có thể mang lại em tin nhắn hoặc skype không ah. Em còn vài ba sự việc cần yếu giải quyết được đề xuất góp ah. Em cảm ơn anh không ít ah.


*

Quý Khách ơi, mình cai thongcongnghetaz.com tiên tiến nhất là php7.1cơ mà 1 số ít source nó chỉ chạy dc php5.6vậy yêu cầu làm cho nỗ lực nào? b lý giải m với


*

Phương thơm án 1. Bạn chạy trên VPS tải thongcongnghetaz.com với PHP5.6 (Reinstall VPS cũ download mới). Khuyến khích phương án này hơnPhương án 2. quý khách hàng downgrade PHPhường., có thể sẽ có được xung thốt nhiên yêu cầu nên backup trang web trước để mua lại Lúc cần# yum-config-manager --disable remi-php71# yum remove php-fpm php-common php-gd php-mysqlnd php-pvì chưng php-xml php-mbstring php-mcrypt php-curl php-opcabít php-cli php-pecl-zip# yum-config-manager --enable remi-php56# yum install php-fpm php-comtháng php-gd php-mysqlnd php-pbởi vì php-xml php-mbstring php-mcrypt php-curl php-opcađậy php-cliKiểm tra php.ini trường hợp vẫn giữ nguyên của thông số kỹ thuật PHP7.1 trước đó và khối hệ thống tạo thành file php.ini.rpmsave sầu mang lại thông số kỹ thuật PHP. bắt đầu thì:mv /etc/php.ini /etc/php.ini.bkmv /etc/php.ini.rpmsave sầu /etc/php.iniRồi khởi động lại PHP-FPM


*

Chào admin,Mình tất cả tải thêm chiếc thỏng viện: https://thongcongnghetaz.com/ioncube-loader/. Nhưng sau thời điểm reboot lại server thì phpmyadmin singin không được nữa, và filemanager cũng triệu chứng như vậy. Không báo lỗi gì, submit đăng nhập đưa ra refresh lại trang nhưng không vào cai quản được. Rất ao ước admin học vps chỉ bảo giùm, để bản thân fix được lỗi này :(.Chân thành cám ơn.


*

Mình cyếu đoạn này xuống bên dưới thuộc của PHPhường Ini rồi xong xuôi có tác dụng nắm như thế nào để khởi đụng lại được hả các bạn ơi.

=================================== zend_extension = /usr/lib64/php/modules/ioncube_loader_lin_5.6.so======================================


*

quý khách hàng dùng web-VPS gì? Nginx thìservice php-fpm restartservice nginx restartApache thì service httpd restart


*

Mình sử dụng ZOC nhằm msinh sống tệp tin php.iniPaste chấm dứt code dưới dẫu vậy bản thân k biết có tác dụng tnao để restart lại.zend_extension = /usr/lib64/php/modules/ioncube_loader_lin_5.6.so


*

Mình setup Ok mà lại nhưng mà không hiểu biết sao Lúc update website trình thông báo vẫn báo cần được bao gồm phiên bản tự 5.1 trsinh sống lên.

Xem thêm: Dạy Học Theo Chủ Đề Môn Toán Cấp Quận Với Chủ Đề “Dạy Học Theo Chủ Đề”

Đây là Log check của mình muốn chúng ta hỗ trợ.

Đã thêm dòng : zend_extension=/usr/local/ioncube/ioncube_loader_lin_5.4.so vào file php.ini

Mình tất cả rất cần phải Update phiên phiên bản PHPhường lên ko ?


*

Luân cho khách hàng hỏi bao gồm bí quyết nào dịch trở lại những file bị mã hóa vị thằng này không?


*

Hi , anh luân , tải php 5.6 với ionCube Loader 5.6 , báo số đông lắp thêm thành công , nhưng lại lại chạy không dươc anh luân


*

Nó có lợi gì mang đến Server thường xuyên ko các bạn
Chuyên mục: Blogs